Delayed Payments and SMS processing
Incident Report for Angaza
Resolved
This incident has been resolved.
Posted Jun 01, 2023 - 11:30 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 01, 2023 - 11:04 PDT
Investigating
We are currently investigating this issue.
Posted Jun 01, 2023 - 10:20 PDT
This incident affected: Global Status (Other PAYG Services).