Resolved
This incident has been resolved.
Posted Jul 17, 2026 - 21:59 EAT
Update
We are continuing to work on a fix for this issue.
Posted Jul 17, 2026 - 11:28 EAT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 17, 2026 - 11:25 EAT
Investigating
The gsm usage data service is currently undergoing an outage, our team is investigating the incident.
Posted Jul 17, 2026 - 11:18 EAT
This incident affected: Regional Status (Uganda, Myanmar, Sierra Leone, Kenya, Tanzania, Senegal, Nigeria, Rwanda, DR Congo, Benin, Madagascar, Mozambique, Zimbabwe, Philippines, Zambia, India, Malawi, Mali, Côte d'Ivoire, Somalia, Namibia, Pakistan, Panama, Nicaragua, Ghana, Papua New Guinea, Haiti, South Africa, Burkina Faso, Vanuatu, Peru, Nepal, Chad, Ethiopia, Indonesia, Chile, Togo, Cameroon, Guatemala, Liberia, Burundi, Niger) and Global Status (Other PAYG Services).