Degraded Hub Performance

Incident Report for Angaza

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 00:42 EAT

Monitoring

SMS message statuses are now being updated without delay. We will continue to monitor the services as they fully recover.
Posted Oct 21, 2025 - 00:22 EAT

Update

Payment processing is now instant, SMS messages are being deliverd with a delay in updating message status.
Posted Oct 20, 2025 - 23:33 EAT

Identified

We are currently experiencing an incident impacting the Hub and other services, due to Cloud service provider outage and 3rd party provider outages. We have slow SMS deliveries and delayed payment processsing.
Posted Oct 20, 2025 - 19:29 EAT
This incident affected: Global Status (Angaza Energy Hub, Other PAYG Services).