Customers unable to make payments with Airtel Madagascar

Incident Report for Angaza

Resolved

This incident has been resolved.
Posted Apr 05, 2023 - 20:26 EAT

Update

We are continuing to work on a fix for this issue.
Posted Feb 24, 2023 - 12:33 EAT

Update

Airtel Tanzania is operational. We are continuing to work on a fix for this issue for Airtel Madagascar.
Posted Feb 24, 2023 - 10:52 EAT

Identified

The issue has been identified and we are working with Airtel Tanzania to implement a solution
Posted Feb 22, 2023 - 11:27 EAT
This incident affected: Regional Status (Tanzania, Madagascar).