Issue processing some mobile money payments
Incident Report for Angaza
Resolved
This incident has been resolved.
Posted Jan 11, 2025 - 13:37 EAT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 11, 2025 - 13:24 EAT
Investigating
We are experiencing trouble processing payments for some payment providers.
The team has identified the issue and is working on a solution.
Posted Jan 11, 2025 - 11:59 EAT
This incident affected: Global Status (Angaza Energy Hub, Angaza Activator, Other PAYG Services).