User Creation Issue via the Angaza Hub

Incident Report for Angaza

Resolved

This incident has been resolved. Users can be created and edited via the Hub UI again.
Posted Aug 27, 2025 - 01:58 EAT

Update

We are continuing to make progress on resolving the issue, and soon you will be able to create and edit users via the Hub UI.

In the meantime, you can use the Bulk Actions tool under the Users page to create and edit users:

https://support.angazadesign.com/hc/en-us/articles/360001539852-Create-User

Thank you for your patience and understanding as we work to fully restore functionality.
Posted Aug 26, 2025 - 18:46 EAT

Identified

We’ve identified the issue affecting user creation and are actively implementing a fix. Thank you for your patience as we work to resolve this.
Posted Aug 26, 2025 - 16:04 EAT
This incident affected: Global Status (Angaza Energy Hub).