Third Party APIs Down

Incident Report for Angaza

Resolved

Issues with third-party Keycode provider APIs have been resolved. We will continue to monitor for any new errors.
Posted Nov 18, 2025 - 17:50 EAT

Investigating

We are currently experiencing issues with our third-party Keycode provider APIs. This has been communicated to the keycode providers, and the issues are being investigated. In the meantime, payments to accounts related to our third-party APIs are delayed. We will continuously provide updates here.
Posted Nov 18, 2025 - 16:37 EAT
This incident affected: Global Status (Other PAYG Services).