Telma Madagascar Mobile Money Payments Outage
Incident Report for Angaza
Resolved
This incident has been resolved.
Posted Oct 14, 2021 - 04:10 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 14, 2021 - 04:04 PDT
Investigating
We are currently investigating this issue.
Posted Oct 14, 2021 - 03:45 PDT